fuse: bad mount point - Transport endpoint is not connected

I mount various directories over ssh for convenience. Occasionally the connection gets interrupted and this leads to errors like: fuse: bad mount point /mnt/foo: Transport endpoint is not connected

It took me a little time to find out how to fix this problem:

  1. kill the sshfs process(es)
  2. umount -l /mnt/foo (as root)
  3. mount the sshfs again

I suppose this happens with other networked filesystems as well, or at least with other fuse filesystems.

If your connection drops only temporarily using the reconnect option should fix this problem as well.

Published on Oct. 4, 2010 at 3 p.m. by Nicolas and tagged sshfs, Linux, fuse. You can follow the discussion with the comment feed for this post. Feeling generous? Donate!

21 comments

  1. avatar
    wrote this comment on

    I've had this come up a lot with my fuse ftp fs. THANKS!!! Fixed. You rock!

  2. avatar
    wrote this comment on
    This was helpful until I had enough of doing it every hour or so, so I added

    -o reconnect -C -o workaround=all

    and let sshfs figure it out for itself.
  3. avatar
    wrote this comment on
    beautiful answer, it solved my problem in no time, couldn't figure it out either...
  4. avatar
    wrote this comment on
    thanks, big help.
  5. avatar
    wrote this comment on
    Wow, been searching for a while. Nice one.
  6. avatar
    wrote this comment on
    Thanks you!!! This was a HUGE help!
  7. avatar
    wrote this comment on
    Thanks, that worked for me
  8. avatar
    wrote this comment on
    Wasted only 20 minutes thank to this small piece of code. Thanks !!!
  9. avatar
    wrote this comment on
    Thats an Awesome Tip !! thanks a lot man
  10. avatar
    wrote this comment on
    helped, thanks!
  11. avatar
    wrote this comment on
    Thank you so much. Your suggestion is incredibly helpful.
  12. avatar
    wrote this comment on
    Thank you brother! Worked well!
  13. avatar
    wrote this comment on
    Thanks! Works very well
  14. avatar
    wrote this comment on
    Thank you
  15. avatar
    wrote this comment on
    Works perfectly!!!
  16. avatar
    wrote this comment on
    Thanx! It worked for me!
  17. avatar
    wrote this comment on
    Thanks a stack. You sure saved my bacon after a failed upgrade.
  18. avatar
    wrote this comment on
    Thanks so much!
  19. avatar
    wrote this comment on
    Thanks
  20. avatar
    wrote this comment on
    Hello

    So, i'm a neophite in the field. how do i mout the sshfs again ?

    Tahnks
    1. avatar
      wrote this comment on
      Install sshfs and see man sshfs, it has examples.

Start a new thread

Cancel reply
Markdown. Syntax highlighting with <code lang="php"><?php echo "Hello, world!"; ?></code> etc.